Blog

Script para geral usuários no hotspot em Mikrotik

  • Domingos Nunes
  • 29/08/2020
  • Blog

É um trabalho chato criar os usuários e as senhas no hotspot com Mikrotik de um hotel por exemplo. E mais trabalho quando tem que mudar a senha.

O script gera usuários e senha em hotspot mikrotik usando uma lógica de sequência.

Em hotel por exemplo com apartamentos de 901 a 920, o script vai gerar os usuários de 901 a 920 e senha 90012020 a 90202020

Não esqueça de fornecer o nome do User Profile(profile=) no exemplo usei PAGO e do Server(server=) no exemplo usei HOSPEDE-SERVER

/ip hotspot user

: for i from=1 to=3 do={ add name=(“900”.$i) password=(“900”.$i.”2020″) profile=PAGO server=HOSPEDE-SERVER};

Resultado:

add name=9001 password=90012020 profile=PAGO server=HOSPEDE-SERVER

add name=9002 password=90022020 profile=PAGO server=HOSPEDE-SERVER

add name=9003 password=90032020 profile=PAGO server=HOSPEDE-SERVER

Analisando o script:

For i from=1 to=3 significa: fazer de 1 a 3

add name=(“900”.$i) significa fazer 9001, 9001, 9003

password=(“900”.$i.”2020″) significa fazer senha 9012020, 9022020, 9032020

profile=PAGO e server=HOSPEDE-SERVER é o servidor e perfil

Veja também:

Quero saber sua opinião